Back to overview
Downtime
Some services are down
May 1, 2024 at 9:53am UTC
Resolved
May 3, 2024 at 3:00pm UTC
dev.mycatalogcloud.com is working again
Affected services
Created
May 1, 2024 at 9:53am UTC
mycatalogcloud.com Development Cloud Server went down due to migration to new Java/TC versions
Affected services